[Gluster-users] starting 4th node in 4 node dht cluster fails

J. Timothy Kwiatkowski jtk at octopus.scif.ou.edu
Wed Feb 25 16:46:57 UTC 2009

> I tried this but still get the same result (3 nodes ok, 4th node breaks it - doesn't matter which the 4th node is). "getfattr -d" returned nothing on the mount directory btw.

I had this same sort of problem.  Do a man on getfattr and you will find
that the -m option is needed since it will only return extended attributes
that match the pattern "^user\\." by default.  If you use:

    getfattr -d -m '\.' /path-to-backend

And you will get something like

getfattr: Removing leading '/' from absolute path names
# file: local/scratch2

After using a setfattr -x trusted.glusterfs.dht on the backend mount points
everything worked again.

I just recently installed 2.0.0rc1 and set up the nufa translator on
top of the afr translator after trying out nufa alone across my cluster.
Unfortunately I made a couple of small mistakes in the configuration and
got the "Structure needs cleaning" issue.  So I kept banging my head until
I found this solution.


| J. Timothy Kwiatkowski, PhD   jtk at ou.edu      (405) 325-6913   |
| SCIF (Shell Crustal Imaging Facility, Geology and Geophysics)  |
| SEC E1468                                   (Mailing SEC 810)  |
| University of Oklahoma                                         |

More information about the Gluster-users mailing list