[Gluster-users] Xen and Glusterfs

Matt Lawrence matt.lawrence at tamu.edu
Fri Apr 3 20:22:31 UTC 2009

Mathijs Krullaars wrote:
> I would try it with disk = [ "file:/storage/xen/felluca.img,xvda,w" ]
> If that still wouldn't work, i would make the xen image locally without 
> glusterfs, so you know you have a working image, and then copy the image to 
> glusterfs and try to start it from there.
> At this moment you have a problem that can have a cause on multiple places, so 
> i would simplify it first by making a working xen image first instead of 
> trying to get the whole thing going at once.
> This is a typical cfg i use that does work:
> # general
> name    = "http1";
> memory  = 512;
> # booting
> kernel  = "/var/xen/domUs/domU-kernels/vmlinuz-2.6.20-r6-xenU";
> # virtual harddisk
> disk = [ "file:/var/xen/domUs/images/http1-domU/domU-http1-root,xvda,w",
> 	 "file:/var/xen/domUs/images/http1-domU/domU-http1-tmp,xvdb,w",
> 	 "file:/var/xen/domUs/swapspace/domU-http1-swap,xvdc,w" ];
> root = "/dev/xvda ro";
> # virtual network
> vif = [ "bridge=xenbr0","bridge=xenbr1" ];

Ok, tried that.  Installed on a local disk and it worked.  Changed the 
"tap:aio" to "file", made sure it still worked, then copied it to 
gluster file system and it works.  Try to do an install to the gluster 
file system and it still hangs.  So I'm guessing the problem is in the 
"tap:aio" disk access that virt-manager configures when I build a VM 
through its GUI. 

Any insights on why that is a problem?  Or how to convince virt-manager 
to use "file"?

Thanks for the help!

-- Matt

More information about the Gluster-users mailing list