[Gluster-users] Xen and Glusterfs

Mathijs Krullaars Mathijs at atct.nl
Fri Apr 3 15:16:58 UTC 2009

Can you post your gluster configs, xen configs, fstab of the image you try to 
boot, etc?

I have a farm running xen with live migration that is all working fine, so i 
might be able to help you with your trouble.

On Thursday 02 April 2009 22:19:16 Matt Lawrence wrote:
> Anand Avati wrote:
> > Try mounting glusterfs with --disable-direct-io-mode
> >
> > Avati
> >
> > On Wed, Apr 1, 2009 at 6:54 PM, Matt Lawrence <matt.lawrence at tamu.edu> 
> >> I am having problems trying to run xen virtual machines with a disk
> >> image located on glusterfs storage.  They hang at "Creating root device"
> >> while booting.  Any ideas?
> Ok, tried that.  Still no luck.  Even trying to install to a disk image
> file on a glusterfs volume wedges parts of Xen.  Takes a reboot of the
> physical host to get the virtual machine fully terminated.  Help?
> -- Matt
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://zresearch.com/cgi-bin/mailman/listinfo/gluster-users

More information about the Gluster-users mailing list