[Gluster-users] How to debug unify self-heal ?

Raghavendra G raghavendra.hg at gmail.com
Fri Oct 10 08:19:43 UTC 2008

Is unify-self-heal on? (since you're saying you tried deleting the whole
namespace and able to list the files except for some, self-heal should be
on. But I just wanted to confirm it).

Can you try deleting the whole namespace and restart glusterfs freshly? Can
you mail the log files, If you can reproduce the error?If it does not take
too much time to reproduce the error, please start glusterfs with loglevel
of DEBUG (-L DEBUG on command line).

Also, please send the version of glusterfs you are using.

On Fri, Oct 10, 2008 at 8:58 AM, Will Rouesnel <
electricitylikesme at hotmail.com> wrote:

>  ------------------------------
> *From:* Raghavendra G [mailto:raghavendra.hg at gmail.com]
> *Sent:* Friday, October 10, 2008 3:37 PM
> *To:* Will Rouesnel
> *Cc:* Krishna Srinivas; gluster-users at gluster.org
> *Subject:* Re: [Gluster-users] How to debug unify self-heal ?
> On Fri, Oct 10, 2008 at 7:36 AM, Will Rouesnel <
> electricitylikesme at hotmailcom <electricitylikesme at hotmail.com>> wrote:
>> Periodically on my gluster setup, unify will fail to display the files
>> that
>> are some of the bricks. The only way I've found to correct this is to
>> delete
>> the containing directory from the glusterfs mount and then recopy it
>> through
>> the glusterfs mount.
>> The files on the bricks themselves are fine and if I access them directly
>> they are perfectly usable.
>> What I can't work out, is what property of the files comes up that causes
>> this behavior from unify. I'm not using AFR, and if I try to directly
>> access
>> the files then the unify log will generate an error indicating it found
>> the
>> file on the brick but not in the namespace. However if I list the contents
>> of the directory, the file does not show up.
> Are the files which you cannot ls on glusterfs mount present on the
> namespace node?
> No they are not. I've tried deleting the namespace node and letting
> it rebuild, but for the files for which I have the problem this does not
> recreate them on the namespace node either. The thing is I can't find
> anything wrong with the files which would stop gluster from accessing them,
> nor any attributes it might be reacting to.

Raghavendra G
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20081010/79ea17d2/attachment.html>

More information about the Gluster-users mailing list