[Gluster-users] FYI: lighttpd w. libglusterclient stopped working

Dan Larsen dan at relax.dk
Thu Dec 4 10:15:27 UTC 2008


this is just to make sure, that you know of this problem and maybe  
help somebody having the same problem.

I wanted to try out the glusterfs with lighttpd.
I downloaded 1.4.0pre13 and followed the instructions.
I constantly got the following errors from the glusterfs log:

2008-12-04 10:11:08 E [client-protocol.c:4790:client_setvolume_cbk]  
machinename: SETVOLUME on remote-host failed: ret=-2 error=Invalid  
2008-12-04 10:11:08 E [dict.c:2183:dict_unserialize] dict: undersized  
buffer passsed

then i tried the same thing, on a different server and got the same  
I then tried to downgrade to 1.4.0pre7 - that solved the problem!

I have no idea, whether this is caused by 1.4.0pre13 libglusterfs*  
trying to access a gluster running 1.4.0pre7
or whether it is a bug in 1.4.0pre13 - but now you know ;-)

Best regards
Dan Larsen

More information about the Gluster-users mailing list