[Gluster-devel] intermittent test failure: tests/basic/tier/record-metadata-heat.t ?

Vijay Bellur vbellur at redhat.com
Mon Dec 7 23:58:29 UTC 2015

On 12/07/2015 06:51 PM, Vijay Bellur wrote:
> On 12/07/2015 06:47 PM, Michael Adam wrote:
>> FYI: tests/basic/tier/record-metadata-heat.t failed in
>> https://build.gluster.org/job/rackspace-regression-2GB-triggered/16562/consoleFull
>> triggered for
>> http://review.gluster.org/#/c/12830/
>> I can see no relation.
>> (In fact, that patch should not add any new failures.)
> tests/basic/tier/record-metadata-heat.t is listed in is_bad_test().
> Hence this failure should not affect the result of a regression run.
> Dan mentioned to me earlier today that a fix is being worked on for this
> test marked as bad.

Looks like the run failed due to:

/tests/bugs/fuse/bug-924726.t (Wstat: 0 Tests: 20 Failed: 1)
   Failed test:  20

Raghavendra - this test has been reported previously too as affecting 
other regression runs. Can you please take a look in as you are the 
original author of this test unit? I tried reproducing the problem in my 
local setup a few times but that does not seem to happen easily.


More information about the Gluster-devel mailing list