[Gluster-devel] Dependency issue while installing glusterfs-3.6beta with vdsm

Kaleb S. KEITHLEY kkeithle at redhat.com
Tue Oct 28 12:42:00 UTC 2014

On 10/28/2014 07:48 AM, Darshan Narayana Murthy wrote:
> Hi,
>      Installation of glusterfs-3.6beta with vdsm (vdsm- fails on
> f19 & f20 because of dependency issues with qemu packages.
>      I installed vdsm- which installs glusterfs-3.5.2-1.fc19.x86_64
> as dependency. Now when I try to update glusterfs by downloading rpms from :
> http://download.gluster.org/pub/gluster/glusterfs/qa-releases/3.6.0beta3/Fedora/fedora-19/
> It fails with following error:
> Error: Package: 2:qemu-system-lm32-1.4.2-15.fc19.x86_64 (@updates)
>             Requires: libgfapi.so.0()(64bit)
>             Removing: glusterfs-api-3.5.2-1.fc19.x86_64 (@updates)
>                 libgfapi.so.0()(64bit)
>             Updated By: glusterfs-api-3.6.0-0.5.beta3.fc19.x86_64 (/glusterfs-api-3.6.0-0.5.beta3.fc19.x86_64)
>                ~libgfapi.so.7()(64bit)
>             Available: glusterfs-api-3.4.0-0.5.beta2.fc19.x86_64 (fedora)
>                 libgfapi.so.0()(64bit)
> Full output at: http://ur1.ca/ikvk8
>      For having snapshot and geo-rep management through ovirt, we need glusterfs-3.6 to be
> installed with vdsm, which is currently failing.
> Can you please provide your suggestions to resolve this issue.


Starting in 3.6 we have bumped the SO_VERSION of libgfapi.

You need to install glusterfs-api-devel-3.6.0... first and build vdsm.

But....  we are (or were) not planning to release glusterfs-3.6.0 on f19 
and f20...

Off hand I don't believe there's anything in glusterfs-api-3.6.0 that 
vdsm needs. vdsm with glusterfs-3.5.x on f19 and f20 should be okay.

Is there something new in vdsm-4-14 that really needs glusterfs-3.6? If 
so we can revisit whether we release 3.6 to fedora 19 and 20.



More information about the Gluster-devel mailing list