[Gluster-devel] [Gluster-users] Please test GlusterFS 3.6.0 beta3 on OSX!

Dennis Schafroth dennis at schafroth.dk
Sat Oct 25 08:16:35 UTC 2014

Trying to test OSX towards a Linux (debian 7.7) server, but seems to get the same error on both OS X and Linux when attempting to mount:

Running beta3 on both. 

sudo mount -t glusterfs -o 'log-file=/usr/local/var/log/glusterfs/dist-rep.log' bd:dist3 ~/dist-rep

[2014-10-25 08:00:22.267617] I [MSGID: 100030] [glusterfsd.c:2018:main] 0-/usr/local/sbin/glusterfs: Started running /usr/local/sbin/glusterfs version 3.6.0beta3 (args: /usr/local/sbin/glusterfs --log-file=/usr/local/var/log/glusterfs/dist-rep.log --volfile-server=bd --volfile-id=dist3 /Users/dennis/dist-rep)
[2014-10-25 08:00:22.268115] I [options.c:1163:xlator_option_init_double] 0-fuse: option attribute-timeout convertion failed value 1.0
[2014-10-25 08:00:22.268132] E [xlator.c:425:xlator_init] 0-fuse: Initialization of volume 'fuse' failed, review your volfile again

I have tried with an old (created with 3.5.x) and a newly created (3.6.0 beta3) volume.

Also, trying to use multiple options when mount fails on OS X: 

mount -o log-level=trace,log-file=/var/log/glusterfs/dist-rep.log  -t glusterfs bd:dist-rep /mnt/adc1

fails on OS X with: 

ERROR: Server name/volume name unspecified cannot proceed further..
Please specify correct format
man 8 /sbin/mount_glusterfs


> On 24 Oct 2014, at 22:13 , Dennis Schafroth <dennis at schafroth.dk> wrote:
> I installed the OSXFUSE 2.7.2 package and commented out the osxfuse dependency in glusterfs.rb and it installed fine on Yosemite. 
> cheers, 
> :-Dennis
>> I'm trying to build on my shiny new Yosemite machine...  `brew install osxfuse` tells me:
>> osxfuse: OS X Mavericks or older is required for this package
>> OS X Yosemit introduced a strict unsigned kext ban which breaks this package.
>> You should remove this packager from you system and attemnpt to find upstream binaries to use instead.
>> Error: An unsatisfied required failed this build.
>> Did you have osxfuse installed before you upgraded to Yosemite?
>> --
>> Kaleb
>> _______________________________________________
>> Gluster-users mailing list
>> Gluster-users at gluster.org
>> http://supercolony.gluster.org/mailman/listinfo/gluster-users
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org <mailto:Gluster-users at gluster.org>
> http://supercolony.gluster.org/mailman/listinfo/gluster-users <http://supercolony.gluster.org/mailman/listinfo/gluster-users>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-devel/attachments/20141025/a1bf0587/attachment.html>

More information about the Gluster-devel mailing list