[Gluster-devel] Embedding debug symbols in glusterfsd

Lluís Pàmies i Juárez llpamies at pamies.cat
Tue Feb 4 22:27:30 UTC 2014


I'm trying to compile glusterfs-3.4.2 with debugging information.

I tried:

   ./configure --prefix=/usr --enable-debug=yes
   make install

But when I do "gdb glusterfsd" I'm still getting a "no debugging symbols
found" message.

I also tried with "export enable_debug=yes" as suggested in [1] without

At the end of ./configure it indeed says "Enable Debug: yes", and when
doing "make -n" I can see that the correct flags "-g -O0" are passed to
gcc. My guess is that at some point of "make install" the debug symbols are
striped, but I don't see where.

Can anyone guide me on how to embed the debug symbols in the gluster daemon?

[1] http://www.gluster.org/pipermail/gluster-users/2013-December/038390.html


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-devel/attachments/20140204/f09cf453/attachment-0001.html>

More information about the Gluster-devel mailing list