[Gluster-devel] Smoke test question

Luis Pabon lpabon at redhat.com
Tue Apr 15 03:54:16 UTC 2014

Thank you for the quick reply.  I add the host xfs directory to the container using the docker -v switch to the 'run' command.  It works really well.  I probably need to clarify that the steps highlighted below are not run inside the container, but instead I run them on the host system.  I tried both CentOS 6.5 and Fedora 19 and both systems failed to pass the posix compliance tests on xfs and ext4.  I need to see how to make the tests pass consistently on the local file systems. Once I do that, then I can investigate running the tests inside the container.


> On Apr 14, 2014, at 10:51 PM, Jay Vyas <jayunit100 at gmail.com> wrote:
> Great that your attempting to get it working in docker.
> I remember reading an email or two about this... Is this related to the way that docker containers use that copy on write filesystem or maybe the AUFS that docker uses as default for setup of container?
>> On Apr 14, 2014, at 9:11 PM, Luis Pabon <lpabon at redhat.com> wrote:
>> Hi guys,
>>   I am investigating running smoke tests inside Docker.io, but I cannot seem to pass the posix-compliance tests.  I then tried to run the posix-compliance tests on XFS and EXT4 but I could make them pass there either.  This is what I did:
>> $ truncate -s 5G mydisk
>> $ sudo mkfs.xfs mydisk
>> $ sudo mount -o loop mydisk /mnt
>> $ cd /mnt
>> * Change the value of 'fs' in ~/qa/tools/posix-compliance/conf according to the file system format.
>> $ prove -r ~/qa/tools/posix-compliance/tests
>> They always fail on chown tests.  Anyone know why?
>> - Luis
>> _______________________________________________
>> Gluster-devel mailing list
>> Gluster-devel at nongnu.org
>> https://lists.nongnu.org/mailman/listinfo/gluster-devel

More information about the Gluster-devel mailing list