[Gluster-devel] LOOKUP gets wrong EACCESS during self heal

Pranith Kumar Karampuri pkarampu at redhat.com
Thu Dec 26 12:14:49 UTC 2013

In brick xlators, Only posix, posix-acl give EPERM (I don't think it is EACESS).
posix gives EPERM only if the lookup is performed on .glusterfs of the brick.
Bit that is not the case so I am thinking it is coming from posix-acl. If you
have a re-creatable test case, may be we should add some logs in that xlator and
see what the issue is.


----- Original Message -----
> From: "Emmanuel Dreyfus" <manu at netbsd.org>
> To: gluster-devel at nongnu.org
> Sent: Thursday, December 26, 2013 4:22:58 PM
> Subject: [Gluster-devel] LOOKUP gets wrong EACCESS during self heal
> Hi
> Another bug on 3.5.0qa3: A volume was self-healing, and suddently I
> got on a brick:
> [2013-12-26 10:43:40.306926] I [server-rpc-fops.c:147:server_lookup_cbk]
> 0-gfs351-server: 64274768: LOOKUP /manu
> (00000000-0000-0000-0000-000000000001/manu) ==> (Permission denied)
> Of course the directory permission never changed, at least on purpose.
> The message is repeated meny times as the running processes got their
> failures. When I discovered the failure, I tried a ls /manu, in ordrer
> to cause a LOOKUP, and it worked fine.
> --
> Emmanuel Dreyfus
> manu at netbsd.org
> _______________________________________________
> Gluster-devel mailing list
> Gluster-devel at nongnu.org
> https://lists.nongnu.org/mailman/listinfo/gluster-devel

More information about the Gluster-devel mailing list