[Gluster-devel] Failing to compile on FreeBSD 8.2

Damian Pound dpound at inter-mark.net
Tue Oct 25 16:01:20 UTC 2011

Initially I just did "./configure; make", but configure didn't enable 
the fuse client and make failed because of some operator thing. Then I 
found that FreeBSD uses a different make from GNU/Linux, so I installed 
gmake, still failed but seemed to have more promising errors. I decided 
to try compiling the last version of gluster that supported MacOSX, 
2.0.2, that managed to compile, though I haven't tested it since it is 2 
years old. I went to get gcc 4.6.0 since there were a lot of changes 
since 4.2.1, this made the compile of 2.0.2 and 2.0.9 enable fuse, but 
3.1.7 and 3.2.4 still don't enable it. I tried --enable-fuse-client a 
few times, but that was either ignored or the configure failed.

So that was some of the stuff I did, heres some info about my machine 
and the configure/make of those 4 versions I tried 

~Damian Pound

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-devel/attachments/20111025/9e48a421/attachment-0003.html>

More information about the Gluster-devel mailing list