[Gluster-devel] is gluster tested against ARM machines ?

Hraban Luyat hraban at 0brg.net
Thu Sep 30 10:15:47 UTC 2010

Hello Yann,

In fact, yes, it has been tested: I tried to install it on a QNAP
TS-110 about a year ago. It was a small disaster, that eventually led
me to start working on my own distributed file system. Not to
discredit GlusterFS: it just simply is not suited for this
architecture, apparently. At least when I tried, it was not. I think
it was best illustrated by a private e-mail from one of the devs to my
bugreports and patches for this arch: "We are curious to know the
purpose of using glusterfs - a clustered filesystem - on an embedded
systems platform."

To be honest: I consider this a good thing. GlusterFS sounds like it
is doing a very good job in the area it was designed for: high
performance computer clusters (right?). The price I have to pay for
this dedication (namely: not being able to use GlusterFS myself) is
one that I have to bear: the world is better off this way, I would

Anyway. My point is just: I abandoned GlusterFS for ARM and started
development of my own, much more general purpose, "distributed FS",
with compatibility as a higher requirement than cluster performance,
orthogonal to GlusterFS instead of competing with it (why would I,

I hope this does not sound tongue in cheek: I definitely do not intend
it to. I mean it: I love the fact that GlusterFS is doing good and I
find it a pitty that it was not suitable for my ends. Creating new
distributed filesystems is not my favourite pass-time (maybe it
secretly is).


Hraban Luyat

2010/9/29 Yann Dupont <Yann.Dupont at univ-nantes.fr>:
>  Hello. I'm trying glusterfs 3.1 Beta on small servers (pogoplugs)
> root at tom:/opt/gluster/sbin# ./glusterfsd
> glusterfsd: mem-pool.c:280: __gf_free: Assertion `0' failed.
> Aborted (core dumped)
> those puppies have only 128 MB of ram, maybe this is the cause ??
> root at tom:/opt/gluster/sbin# arch
> armv5tel
> Processor    : Feroceon 88FR131 rev 1 (v5l)
> BogoMIPS    : 1192.75
> Features    : swp half thumb fastmult edsp
> CPU implementer    : 0x56
> CPU architecture: 5TE
> CPU variant    : 0x2
> CPU part    : 0x131
> CPU revision    : 1
> Hardware    : Marvell SheevaPlug Reference Board
> Revision    : 0000
> Serial        : 0000000000000000
> on x86, I don't have this bug (compiled from same source)
> --
> Yann Dupont - Service IRTS, DSI Université de Nantes
> Tel : - Mail/Jabber : Yann.Dupont at univ-nantes.fr
> _______________________________________________
> Gluster-devel mailing list
> Gluster-devel at nongnu.org
> http://lists.nongnu.org/mailman/listinfo/gluster-devel

More information about the Gluster-devel mailing list