[Gluster-devel] Problem with little write/read files in Gluster 3.0.0

Gordan Bobic gordan at bobich.net
Thu Jan 28 15:50:44 UTC 2010

Samuel Hassine wrote:
> Hi,
> I downloaded and installed GlusterFS 3.0.2rc1, I have the same problem. 
> Furthermore, I discovered that not only PHP sessions do not work, but I
> also test to move my /etc/apache2 in the GlusterFS. In 2.0.9 it worked
> very well and now, Apache2 coult not read all modules links very quickly
> and does not start. 

Are you saying that apache fails to start because of the speed at which 
it can read the modules symlinks? I'm not convinced, the chances are 
that you have a different problem.

It also sounds like you have a non-standard apache setup. On my RHEL 
boxen /etc/httpd/modules is a symlink, but the files under it are not. 
Have you tried with a standard out of the box setup on a supported 

> But if I put only the apache2.conf file on the Gluster and other files
> on the HD, it works fine, because Gluster is available, I can read and
> write correctly, but not quickly. And many applications need a fast
> access to their files.

Are you saying that 2.0.9 is faster than 3.0.2rc1? My subjective feeling 
is that 3.0.2rc1 is marginally faster than 2.0.9 was, but the difference 
isn't that noticeable.

On a related note, if you expect _any_ clustered file system (let alone 
a fuse based one) to be anywhere nearly (within an order of magnitude) 
as fast as a local file system, I have to disappoint you - it's not 
going to happen. If your files are static or read-only, you could point 
the things reading them at the local backing store if you are using 
replicate, and point the things doing the writing at the glfs level, 
with a period cronned "ls -laR" on the glfs level to make sure things 
get synced after disconnects and suchlike (normally sync happens on stat()).

> Same thing with eZpublish, that runs very well on Gluster 2.0.9 (because
> ez writes many files and read them), but in GlusterFS 3.0.*, it seems to
> be complicated.

That's not a particularly detailed description of the problem. Please 
list your file and directory paths, what is mounted on what file system, 
and what is symlinked to what.


More information about the Gluster-devel mailing list