[Gluster-devel] Add me too for lockup of system for very simple GlusterFS config...

Mark Mielke mark at mark.mielke.cc
Sun Sep 6 08:44:59 UTC 2009

On 09/06/2009 03:42 AM, Anand Avati wrote:
> On 9/6/09, Mark Mielke<mark at mark.mielke.cc>  wrote:
>> I used a very simple configuration. The server has a posix volume with
>> a server volume. The client has single client brick with a
>> cluster/replicate. I'd show you the volume files, but the server won't shut
>> down and restart to let me show you them, and I'll have to go in to the
>> server room to restart it.

>> If you tell me what commands you would like me to run, I'll try to help out
>> in diagnosing the problem. I am new to GlusterFS, and this was really my
>> first test.
> is it possible to get a dmesg output somehow? anything on the console?
> is this the system running storage/posix (server)? or the fuse mount
> (client) or both?

Not any more - I got impatient and did 'kill -9 -1' to see if that would 
help it shut down, but it only seems to have killed sshd. I will try it 
again tomorrow.

I was using glusterfsd with storage/posix and mount -t glusterfs on the 
same machine.

Another odd symptom for me - which I do not recall others having: I had 
/export/gluster-test as the storage/posix directory, I had mounted as a 
client on /tmp/t, and while cd'ed into /tmp/t, I could change files and 
see them without any hang. It only hung when I tried to cd to /export 
from a separate window to see what effect my changes in /tmp/t had. 
Weird, eh? After this, any SSH in to /home/markm worked, and su to root 
worked, but a cd to / or /export hung. Calls to df would show several 
lines of output and then hang (presumedly on the /export/gluster-test 

That cd / froze, when GlusterFS was exporting /export/gluster-test as 
/tmp/t, makes me doubt that GlusterFS is directly responsible, although 
it seems clear that it was GlusterFS that triggered the problem since I 
have had no problems with the system before I tried this test.

One possibly "weird" configuration I have is that /tmp is a tmpfs file 
system, but even with this configuration, I've never had problems 
mounting any other file system as /tmp/t, and this is a common pattern 
for me. For example, I often mount /tmp/t as the USB drive to rsync data 
to as a alternate backup strategy.

Mark Mielke<mark at mielke.cc>

More information about the Gluster-devel mailing list