[Gluster-devel] Glusterfs not mounting correctly during boot under RHEL 5.2

Gordan Bobic gordan at bobich.net
Wed Nov 5 12:33:53 UTC 2008

Ioannis Aslanidis wrote:

> Gordan Bobic wrote:
>> Ioannis Aslanidis wrote:
>>> Gordan Bobic wrote:
>>>> All sorts of problems still come up regularly, but they get fixed
>>>> pretty quickly. I suggest you try the current release 1.3.12. It's
>>>> still not perfect, but it's a lot less buggy than 1.3.8pre6.
>>> Can you point me at the particular fix for my problem in the current
>>> version? Advising an upgrade without being sure that it will fix the
>>> problem is not a valid option. Which feature/patch may fix my problem?
>> I'm not even aware of there being an easily obtainable list of fixes.
>> You're using beta software, so be prepared for things like this.
> Personally, I do not think that this is a valid/helpful response. If
> there is no list of fixes, then this should be fixed.

Maybe so, but you haven't given any (let along good) reason why you're 
trying to troubleshoot a problem with a more buggy version of the 
package than what is already available. I'm assuming that something like:

# rpmbuild -tb glusterfs-1.3.12.tar.gz

isn't an unreasonable amount of effort?

>>>> As an aside, are you sure the rest of the setup is the same (volume
>>>> specs, firewall rules, etc.). If you are using the same gluster
>>>> binaries on both, your problem is most likely related to an OS
>>>> configuration issue. Have you verified that client/server daemons are
>>>> running? Is fuse module loaded on the client?
>>> I know the problem is probably OS related, this is why I am asking if
>>> someone experienced this before on RHEL 5.2. The firewall rules look
>>> fine. Both the client and the server are running.
>> I'm using RHEL 5.2 (actually CentOS 5.2, but close enough), and I've
>> experienced various issues with various versions, including all current
>> ones. But problems generally get fixed reasonably quickly. Keep up with
>> the version updates and don't use it in production yet.
> As I said before, it works fine in FC and I only experience this issue
> in RHEL 5.2. This is why I am asking for someone using exactly RHEL 5.2
> and glusterfs. Something close enough is not enough. FC is close enough
> as well and it works.

Since you seem to be inferring that the problem is with RHEL 5.2 (rather 
than GlusterFS, since "it works on FC"), why are you asking on the 
GlusterFS list and not on the RHEL support channels?

Are you using the distro supplied fuse module or the modified one that 
allows exporting GlusterFS over NFS?

And FC is nothing like close enough. CentOS is RHEL de-badged whereas FC 
has some fairly fundamental differences (different kernels and no DKMS 
support for one).

Have you tried using the FC kernel on RHEL 5.2?

Have you made sure your network configurations are identical on both FC 
and RHEL? Are you using the same hardware for both (dual booting)? Could 
it be that your RHEL box is is dropping packets (e.g. buggy NIC driver 
dying switch port, etc.)?


More information about the Gluster-devel mailing list