[Gluster-devel] glusterfs -- mainline 2.5 -- patch 690 won't mount [solved]

Jordi Moles jordi at cdmon.com
Tue Mar 4 09:31:56 UTC 2008


thanks, that was it.

i don't know why, /dev/fuse is not created on start. is it because of 
the patch version?

here's how i'm trying to install both fuse and gluster


apt-get install tla

cd /usr/src
tla register-archive http://arch.sv.gnu.org/archives/gluster/
tla get -A gluster at sv.gnu.org glusterfs--mainline--2.5--patch-650 glusterfs  ##o la versió patch que sigui

apt-get install 9base bison btyacc byacc cl-yacc cutils styx bisonc++ compilercache cutils flex yydecode alex perl-byacc python-ply python-pyparsing
apt-get install build-essential libtool automake autoconf

cd /usr/src
wget http://ftp.zresearch.com/pub/gluster/glusterfs/fuse/fuse-2.7.2glfs8.tar.gz
tar xfvzp fuse-2.7.2glfs8.tar.gz
cd fuse-2.7.2glfs8
apt-get install linux-headers-2.6.18-6-xen-amd64 (o la versió de kernel que toqui)
./configure --enable-kernel-module
make install
cd /usr/lib
ln -s /usr/local/lib/libfuse.so.2 libfuse.so.2

cd /usr/src/glusterfs
apt-get install python2.4-dev python2.4 python
./configure --prefix=/usr --disable-server --disable-ibverbs
make install


After that, when i run:


glusterfs -l /var/log/glusterfs/glusterfs.log -L DEBUG -f 
/etc/glusterfs/glusterfs-client.vol /mnt/gluster/


It fails because /dev/fuse is never created.

lsmod shows that fuse kernel module is loaded on boot, and no error is 
logged in the /var/log/* files about fuse.

Do i have to run a script which runs a mknod every time the machine 
boots? This didn't use to happen in earlier patches, installed the exact 
same way.

Thank you.

En/na Basavanagowda Kanur ha escrit:
> Jordi,
>   Please make sure you have loaded fuse kernel module using 'modprobe
> fuse'. If you have already done that, then your /dev/fuse file must be
> missing. Create /dev/fuse using command 'mknod /dev/fuse c 10 229'.
> --
> Gowda

More information about the Gluster-devel mailing list