[Gluster-devel] Selfheal is not working? Once more

Rohan rohan.thale at moneycontrol.com
Thu Jul 31 14:05:45 UTC 2008

I think it was a fluke, my system started working after changing config
file. I think, it is a bug. As 

-----Original Message-----
From: Lukasz Osipiuk [mailto:lukasz at osipiuk.net] 
Sent: Thursday, July 31, 2008 7:27 PM
To: Rohan
Cc: Raghavendra G; gluster-devel at nongnu.org
Subject: Re: [Gluster-devel] Selfheal is not working? Once more

On Thu, Jul 31, 2008 at 1:57 PM, Rohan <rohan.thale at moneycontrol.com> wrote:
> Hi Lukasz,


> I also had same problem. I'm using 2 servers A & B, acting as servers as
> well as clients. Using simple AFR, nothing complicated.
> A <--> B
> I was running 2 separate processes for client and server on same server. I
> face 1970 file/directory creation/modify date time problem on server A. on
> server B everything was fine.
> After changing my configuration file and switching to single process. The
> error is solved.
> Any ways try changing your config file, might work. It worked for me.

I'm not sure if I understand what you are saying. I have single
glusterfsd process on
each serving brick, and single glusterfs project on client (which is
on different machine than
any serving bricks). Which configuration should I change? server? client?

> 2008-07-31 14:10:05 W [posix.c:524:posix_mkdir] posix1: mkdir of
> /mailbox/0/1/XXXXX: No such file or directory
> Any help really appreciated.

I would like to help but unfortunatelly i did not expirience such
problems. We are still
lab-testing glusterfs and not using it in production environment. Hell
i yet to come ;).

> Rohan


Lukasz Osipiuk
mailto: lukasz at osipiuk.net

More information about the Gluster-devel mailing list