[Gluster-devel] About gluster on 32 bits

Timothy Russell tgrussell at eiu.edu
Wed Jan 16 00:31:14 UTC 2008

This is in response to a message posted in your archives as: 
From: 	Bala.A
Subject: 	Re: [Gluster-devel] About gluster on 32 bits
Date: 	Thu, 20 Sep 2007 00:15:46 -0700 (PDT)
User-agent: 	SquirrelMail/1.4.9a

// message omitted

I am putting together a 32-bit cluster and have had some difficulty in compiling the iso from the source. I first note (for your reference) that two of the commands listed in the message are incorrect (as I found out after a little frustration). The command given as:

$ export $PATH=$PATH:/usr/local/gluster-toolchain-on32-32-64/bin

needs to have the '$' character omitted from the first $PATH, otherwise errors abound (I am using Debian, so if this is a distribution-specific problem, please forgive; I didn't test elsewhere). Also, 

wget -Ptarballs -nH http://ftp.zresearch.com/pub/gluster/external/*

doesn't work, because wget won't parse wildcards (same caveat).  Now to the meat of my quandry.  Small problems aside, I worked my way down to the step where make is invoked, but the buck stops there.  Every time I run make, it runs for 1-2 hours, at which time it will die, complaining that it couldn't find some file in the /tarballs directory.  A wget is invoked within make, and it tries to download from http://ftp.zresearch.com/pub/gluster/external/(missing-file.tar.gz), an effort which fails every time.  The missing file is always one that is already on the server (and hence in my /tarballs directory), but with a different version number.  I have gone through about 5 or 6 rounds of this, and at ~2 hours/attempt it is becoming more than a little troublesome.  I regret to say that I haven't recorded and don't remember the files which have caused this behavior, but I have soldiered on and found and downloaded each one in succession (from various and sundry sites, since they are not on your server).  I have finally run into a problem which I cannot surmount, however, with iputils.  The version on your server is iputils_20020927.tar.gz, but make chokes looking for iputils_20070202.tar.gz.  I have found copies of this file in a very few different sources, but every time I download this file, there is some error (the tarball is corrupted or it's missing files when it unpacks, etc.).  Can you please tell me how to fix this problem, or--even better--how to get make to want only the versions of the files you have posted.  Thank you for your time and assistance.

Tim Russell
Eastern Illinois University

More information about the Gluster-devel mailing list