[Gluster-devel] compiling error: yytext

Jordi Moles jordi at cdmon.com
Wed Feb 6 09:40:30 UTC 2008

Hi everyone,

i'm trying to compile the latest versions of every part of glusterfs 
from the source to see if i can fix some issues i've got with earlier 

Fuse does just fine, but glusterfs tarball gives me the following error:


make[2]: Entering directory `/usr/src/glusterfs-1.3.8tla641/glusterfsd/src'
if gcc -DPACKAGE_NAME=\"glusterfs\" -DPACKAGE_TARNAME=\"glusterfs\" 
-DPACKAGE_VERSION=\"1.3.8tla641\" -DPACKAGE_STRING=\"glusterfs\ 
1.3.8tla641\" -DPACKAGE_BUGREPORT=\"glusterfs-support at zresearch.com\" 
-DPACKAGE=\"glusterfs\" -DVERSION=\"1.3.8tla641\" -DSTDC_HEADERS=1 
-DFUSE_USE_VERSION=25 -D_GNU_SOURCE -I../../libglusterfs/src 
-DDATADIR=\"/usr/var\" -DCONFDIR=\"/usr/etc/glusterfs\"  -fPIC -Wall -g 
-O2 -MT glusterfsd.o -MD -MP -MF ".deps/glusterfsd.Tpo" -c -o 
glusterfsd.o glusterfsd.c; \
        then mv -f ".deps/glusterfsd.Tpo" ".deps/glusterfsd.Po"; else rm 
-f ".deps/glusterfsd.Tpo"; exit 1; fi
/bin/sh ../../libtool --tag=CC --mode=link gcc -fPIC -Wall -g -O2   -o 
glusterfsd   glusterfsd.o ../../libglusterfs/src/libglusterfs.la -ldl 
mkdir .libs
gcc -fPIC -Wall -g -O2 -o .libs/glusterfsd glusterfsd.o  
../../libglusterfs/src/.libs/libglusterfs.so -ldl -lpthread
../../libglusterfs/src/.libs/libglusterfs.so: undefined reference to 
../../libglusterfs/src/.libs/libglusterfs.so: undefined reference to `yyin'
../../libglusterfs/src/.libs/libglusterfs.so: undefined reference to `yylex'
collect2: ld returned 1 exit status
make[2]: *** [glusterfsd] Error 1
make[2]: Leaving directory `/usr/src/glusterfs-1.3.8tla641/glusterfsd/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/glusterfs-1.3.8tla641/glusterfsd'
make: *** [all-recursive] Error 1


I've also tried the tla version, but i get the same error.

Has anyone faced this error already?

Thank you.

More information about the Gluster-devel mailing list