[Gluster-devel] glusterfs in virtual machine heavy CPU usage

Brian Taber btaber at diversecg.com
Sat Nov 24 21:49:14 UTC 2007

I am having some strange issues with a glusterfs mount withing a vitual
machine.  I am trying to serve web pages via apache with the home flder
mounted as glusterfs.  The performance is horrible, I go a benchmark, 100
requests with 100 cincurnecy and it takes 25-35 seconds.  the whole time
glusterfs is using 100-150% cpu.  So I moved the share to the virtual
machine host an reconnected via NFS to the home folder.  The test took 2
seconds with next to no CPU usage...  I have tried so many differend
combinations of config files with very little difference.  My setup is ns
on one drive, and 2 bricks on 2 raid5 vols.  I have tried threads,
readahead, writebehind, io-cache, everything I could find.

Second issue, with this setup of the glusterfs being reshared via nfs, I
use vsfdpt for ftp server, and whenever trying to download files from the
server, the glusterfs mount hangs, I have to kill everything and restart
when it hapens...

I have the latest tls version running with fuse fuse-2.7.0-glfs6.

Where can I go from here?  I really need this to work...

More information about the Gluster-devel mailing list