[Gluster-devel] Segmentation fault with afr on dapper using fuse 2.6.3 kernel module

Bernhard J. M. Grün bernhard.gruen at googlemail.com
Mon Apr 30 07:38:00 UTC 2007


Here is my first try of a back trace:
#0  0x00002aaaab182954 in memcpy () from /lib/libc.so.6
#1  0x00002aaaab45a943 in afr_opendir_cbk ()
   from /opt/glusterfs/lib/glusterfs/1.3.0-pre3/xlator/cluster/afr.so
#2  0x00002aaaab351897 in client_opendir_cbk ()
   from /opt/glusterfs/lib/glusterfs/1.3.0-pre3/xlator/protocol/client.so
#3  0x00002aaaab3534d0 in client_protocol_interpret ()
   from /opt/glusterfs/lib/glusterfs/1.3.0-pre3/xlator/protocol/client.so
#4  0x00002aaaab353143 in client_protocol_notify ()
   from /opt/glusterfs/lib/glusterfs/1.3.0-pre3/xlator/protocol/client.so
#5  0x00002aaaaabd0c66 in transport_notify (this=0x54e5f0, event=1)
    at transport.c:148
#6  0x00002aaaaabd13b5 in epoll_notify (eevent=1, data=0x54e5f0) at epoll.c:53
#7  0x00002aaaaabd16a0 in sys_epoll_iteration (ctx=0x7fffffaa9c40)
    at epoll.c:145
#8  0x00002aaaaabd0e24 in poll_iteration (ctx=0x7fffffaa9c40)
    at transport.c:251
#9  0x0000000000403792 in main ()

Does this already help you?
I know it is without debugging symbols. I'll try to get them in - but how?.
In the meantime I also updated to patch-132 and the error is the same.
The coredump I used for that back trace is also from patch-132.
I think the problem is not only present with patch-131. It is just the
version I tried out.


2007/4/30, Anand Avati <avati at zresearch.com>:
> > You can download the logs from http://h0t.de/dapper-logs.tar.gz
> I saw the logs, they only indicate that there was a coredump.
> > I already tried it with the latest tla checkout. I think it was
> > patch-131 that I tried. And that version worked on feisty (that uses
> > the same fuse version).
> Do you mean that patch-131 did NOT work on dapper? you should have a
> coredump from the segfault, is it possible to get a backtrace from that?
> avati

More information about the Gluster-devel mailing list