Re: [Gluster-devel] NFS problem (write error: Operation not permitted) gpvcs at
Wed Apr 11 20:25:34 UTC 2007

Hi avati,

Yes I did already following the README.NFS from fuse source

I tried with fsid=0 and fsid=1.
I also tried to mount it with vers=2, vers=3 and vers=4
(using protocol V2, V3 and V4 of NFS).
I tried locally (on fedora fc4 linux box) with kernel
2.6.15-1.1833_FC4 and kernel 
I tried with Aix and linux client.

Nothing change. Does it work for you ? 

The test is trivial:
1) mount /gfs file on another directory
mount --bind /gfs/fs1 /export/fs2
2) Export it for localhost
cat >> /etc/exports <<!
/export/fs2 localhost(rw,insecure,sync,fsid=0)

restart NFS:
service nfs stop                #K20
service rpcidmapd stop          #K68
/etc/init.d/rpcgssd stop        #K69
/etc/init.d/rpcsvcgssd stop     #K69
service nfslock stop            #K86
service portmap stop            #K87

exportfs -ra
service portmap start           #K87
sleep 2
service nfs start               #K20
sleep 2
service nfslock start           #K86

3) mount it locally
mount -o vers=3 localhost:/export/fs2 /gfs/nfs1
4) try it
touch /gfs/nfs1/file  # work
rm /gfs/nfs1/file # work
ls > /gfs/nfs1/file # fail

Regards FT

------------------------ ALICE C'EST ENCORE MIEUX AVEC CANAL+ LE BOUQUET ! ---------------
Découvrez vite l'offre exclusive ALICEBOX et CANAL+ LE BOUQUET, en cliquant ici
Soumis à conditions.

More information about the Gluster-devel mailing list